Search...

Loading

Wednesday, April 4, 2012

Configure EIGRP on cisco routers

God day!!!

Just want to apologize for my English. I am from Belarus and if there are errors, then feel free to write about them, I will correct them :).
In last post I was told you about how to configure RIP on cisco routers. Today, I want to tell you about how configure EIGRP on devices of this vendor.
Who interested, let’s follow me…



How on last time, I will not stopping on the theory. You can find her in the internet. At once, we go to configuration.
For emulate all our devices and schemes I will use GNS3. Today, we will create and configure this scheme:


All devices have IP-addresses from 172.16.x.x/24 range. Default route for whole network is 0.0.0.0 0.0.0.0 192.168.0.2/24 (in the future we will redistribute them into EIGRP). For testing our job we will use ping from hosts and if he will be, then network work fine.
For more experience we will configure EIGRP with authentication.
Ok, let’s start our work. Go to first router (Router_1):

R1>en
R1#conf t
R1(config)#hostname Router_1
Router_1(config)#interface serial 0/0 – go to interface configuration mode;
Router_1(config-if)#ip address 172.16.20.1 255.255.255.0 – set IP-address;
Router_1(config-if)#clock rate 56000
Router_1(config-if)#description To_Router_2
Router_1(config-if)#ip authentication mode eigrp 100 md5 – enable MD5 authentication for EIGRP process;
Router_1(config-if)#ip authentication key-chain eigrp 100 test – configure key-chain named «test» for authentication;
Router_1(config-if)#no shutdown
Router_1(config-if)#interface fa 0/0
Router_1(config-if)#ip address 172.16.10.1 255.255.255.0
Router_1(config-if)#description To_host
Router_1(config-if)#no shutdown
Router_1(config-if)#exit
Router_1(config)#router eigrp 100 – go to EIGRP configuration mode;
Router_1(config-router)#no auto-summary – turn off the auto-summarization (if enable);
Router_1(config-router)#eigrp log-neighbor-changes – turn on logging all messages of EIGRP in console;
Router_1(config-router)#network 172.16.0.0 – configure network, that will work in EIGRP. In this case, all interfaces that have IP-address from that range will be included in EIGRP;
Router_1(config-router)#exit
Router_1(config)#key chain test – enter to key chain configuration mode;
Router_1(config-keychain)#key 1 – create key №1 (It is recommended that the key number be the same on all routers involved in the configuration);
Router_1(config-keychain-key)#key-string cisco – specify the key-string for the key;
Router_1(config-keychain-key)#exit
Router_1(config-keychain)#exit
Router_1(config)#exit
Router_1#wr
Router_1#


Now, go to second router and make the same configuration:

R2>
R2>en
R2#conf t
R2(config)#hostname Router_2
Router_2(config)#int serial 0/0
Router_2(config-if)#ip address 172.16.20.2 255.255.255.0
Router_2(config-if)#clock rate 56000
Router_2(config-if)#description To_Router_1
Router_2(config-if)#ip authentication mode eigrp 100 md5
Router_2(config-if)#ip authentication key-chain eigrp 100 test
Router_2(config-if)#no shutdown
Router_2(config-if)#exit
Router_2(config)#interface fa 0/0
Router_2(config-if)#ip address 172.16.30.1 255.255.255.0
Router_2(config-if)#no sh
Router_2(config-if)#no shutdown
Router_2(config-if)#exit
Router_2(config)#router eigrp 100
Router_2(config-router)#no auto-summary
Router_2(config-router)#eigrp log-neighbor-changes
Router_2(config-router)#network 172.16.0.0
Router_2(config-router)#exit
Router_2(config)#key chain fortest
Router_2(config-keychain)#key 1
Router_2(config-keychain-key)#key-string cisco
Router_2(config-keychain-key)#exit
*Mar 1 00:39:07.875: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.20.1 (Serial0/0) is up: new adjacency – this message indicates that our routers agreed each other and EIGRP with authentication work fine;
Router_2(config-keychain)#exit
Router_2(config)#int fa 0/1
Router_2(config-if)#ip address 192.168.0.1 255.255.255.0
Router_2(config-if)#no sh
Router_2(config-if)#exit
Router_2(config)#exit
Router_2#wr
Router_2#


Now, let’s stop and check what we have on that moment. We will check a routing table on routers check configuration EIGRP by show commands and check network availability between hosts:





As you can see all routes are presented and network connectivity established. Only one thing we do not have at the moment is default route to remote IP-address (192.168.0.2). Let’s fix this. Go to second router (Router_2):

Router_2#
Router_2#conf t
Router_2(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.2
Router_2(config)#router eigrp 100
Router_2(config-router)#redistribute static
Router_2(config-router)#exit
Router_2(config)#exit
Router_2#


With that commands we add default static route and then we enable redistribution static routes to EIGRP process. As a result all other routers in EIGRP process will know about this network. Let’s check this:



Note that on the first router (Router_1) this route is received on EIGRP and is «external» (flag D* EX), and on the second router (which this route announces), it is marked as a static route by default (S *).
Now, let's ping IP 192.168.0.2 from hosts:



All work fines, network availability is provided :). I congratulate you!!!
For configuration EIGRP available and other commands:
  • Router(config-if)#bandwidth x – sets the bandwidth of this interface to x kilobits to allow EIGRP to make abetter metric calculation;
  • Router(config-router)#metric weights tos k1 k2 k3 k4 k5 – changes the default K values used in metric calculation;
  • Router#show ip eigrp neighbors – display neighbors table;
  • Router#show ip eigrp interfaces – shows information about all interfaces that are working in EIGPR;
  • Router#show ip route eigrp – shows routing table with only EIGRP entries;
For debug EIGRP use these commands:
  • Router#debug eigrp fsm
  • Router#debug eigrp packet
  • Router#debug eigrp neighbor
  • Router#debug ip eigrp neighbor
  • Router#debug ip eigrp notifications
On this, I want to finish this post. I hope it was informative for you and I want to thank you for your attention.

If you have a questions or comments, then do not be afraid to write me!!!! This is my contact information. I will pleased to answer!!!!

I’m waiting for you in next posts!!!

With best regards, Ant0ni0n

2 comments:

  1. First time I commented in a blog! I really enjoy it. You have an awesome post. Please do more articles like this. I'm gonna come back surely. God bless.

    Rica
    www.imarksweb.org

    ReplyDelete
  2. I really enjoyed reading your article. I found this as an informative and interesting post, so i think it is very useful and knowledgeable. I would like to thank you for the effort you have made in writing this article.


    edupdf.org

    ReplyDelete